PowerShell Standard support in AWSPowerShell.NetCore

PowerShell Standard support in AWSPowerShell.NetCore

In 2016, we released AWS Tools for PowerShell Core targeting PowerShell Core 6.0, which provided cross-platform support for macOS and Linux, in addition to Windows. We published this module separately from AWS Tools for Windows PowerShell because it was not compatible with earlier versions of PowerShell.

Last year, Microsoft released PowerShell Standard: a new library that allows the creation of modules with a wide compatibility, spanning from PowerShell 3.0 to the latest version of PowerShell Core (including cross-platform support for macOS and Linux).

With our latest release, 3.3.485.0, AWSPowerShell.NetCore targets PowerShell Standard. When the host environment has .NET Framework 4.7.2 installed, the AWSPowerShell.NetCore module can be used on older versions of PowerShell. Although we suggest that users of legacy PowerShell versions (from 2.0 to 5.1) continue to use the AWSPowerShell module in production environments, we invite you to try AWSPowerShell.NetCore and provide us with feedback at our new AWS PowerShell GitHub repository by creating an issue.

Powershell Module Compatible Powershell Versions Experimental Compatibility
AWSPowerShell 2.0 – 5.1
AWSPowerShell.NetCore 6.0 – 6.1 3.0 – 5.1 (when .NET Framework 4.7.2 is installed)

Based on the feedback from the AWS PowerShell community, we’ll consider making the AWSPowerShell module targeting PowerShell Standard our default offering for any PowerShell version starting with 3.0 (supporting all the way back to Windows Server 2018 R2 SP1). This includes PowerShell Core on Windows, macOS, and Linux.

We’re also interested in feedback from our users if the requirement of .NET Framework 4.7.2 is too restrictive, and if there is a significant portion of users on Windows Server 2008 or later who would have a problem upgrading to the newer .NET Framework. You can provide your feedback here.

from AWS Developer Blog https://aws.amazon.com/blogs/developer/powershell-standard-support-in-awspowershell-netcore/

Sharing is caring!

Comments are closed.